Opened 9 years ago

Closed 9 years ago

#4393 closed bug (worksforme)

GHCi says: ghc: internal error: evacuate: strange closure type 63587

Reported by: chrisdone Owned by:
Priority: normal Milestone: 7.2.1
Component: GHCi Version: 6.12.3
Keywords: Cc: chrisdone@…
Operating System: Linux Architecture: x86
Type of failure: GHCi crash Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

Error:

The error message shown by GHCi to me:

ghc: internal error: evacuate: strange closure type 63587
    (GHC version 6.12.3 for i386_unknown_linux)
    Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug

I'm not sure whether this should be classified as GHCi or GHC the compiler, as I wasn't compiling anything at the time, but maybe something inside GHCi was.

This tends to happen on all my projects. I am unable to directly reproduce it. It is not a particularly big problem as Emacs automatically re-launches GHCi.


Background:

I use GHCi inside Emacs. I forward all my Cabal configure/build and any other Haskell-related scripts through GHCi with :! and all the output is forwarded back by GHCi. Maybe it is merely a GHCi bug in using commands? I only suspect this because I only recall getting bugs like this since I started doing this kind of forwarding -- I may be mistaken in that recollection.

For what it's worth, below I include a list of libraries used. But I don't suspect those to be the cause. I assume that the part of GHCi which runs the :! commands is small and self-contained, so I'll have a bash at testing/fixing that, or at least reproducing the error. I doubt many else use :! like I do.


Libraries used:

syb-0.1.0.2, base-3.0.3.2, extensible-exceptions-0.1.1.1, time-1.1.4, random-1.0.0.2, bytestring-0.9.1.7, haskell-lexer-1.0, pretty-show-1.1.1, convertible-1.0.9.1, utf8-string-0.3.6, HDBC-2.2.6.1, parsec-2.1.0.1, HDBC-postgresql-2.2.3.1, haskelldb-hdbc-2.0, haskelldb-hdbc-postgresql-2.0, MonadRandom-0.1.5, MonadCatchIO-mtl-0.3.0.1, network-2.2.1.8, xhtml-3000.2.0.1, cgi-3001.1.8.1, split-0.1.2.1, safe-0.2, HUnit-1.2.2.3, process-1.0.1.3, haskell98, hslogger-1.1.0, regex-base-0.93.2, regex-posix-0.94.4, regex-compat-0.93.1, MissingH-1.1.0.3, ConfigFile-1.0.6, json-0.4.4

Change History (5)

comment:1 Changed 9 years ago by igloo

Milestone: 7.0.2

So am I right in thinking you just have 1 long-running ghci process (inside emacs)?

The best first step is probably to see if it still happens with 7.0.1.

comment:2 in reply to:  1 Changed 9 years ago by chrisdone

Replying to igloo:

So am I right in thinking you just have 1 long-running ghci process (inside emacs)?

The best first step is probably to see if it still happens with 7.0.1.

Yes, that's right. One long-running (ignoring the intermittent crashes) GHCi process, inside Emacs. The workflow is essentially: load these just-edited .hs files, maybe test some things in the REPL, then run :!cabal build. Repeat. There may be something more to it than that.

I'll go ahead and try 7.0.1. I have some urgent deadlines to complete in a Haskell project, so if I encounter problems e.g. building packages with 7.0.1, I'll have to leave it a while and come back to it in a couple weeks. I'll update the ticket whence I have more information.

comment:3 Changed 9 years ago by simonmar

Status: newinfoneeded

comment:4 Changed 9 years ago by igloo

Milestone: 7.0.27.2.1

comment:5 Changed 9 years ago by simonmar

Resolution: worksforme
Status: infoneededclosed

no further info forthcoming, so closing.

Note: See TracTickets for help on using tickets.