Opened 9 years ago

Closed 9 years ago

#4839 closed bug (worksforme)

RTS assertion failure when heap profiling threaded programs.

Reported by: benl Owned by:
Priority: high Milestone: 7.2.1
Component: Runtime System Version: 7.0.2
Keywords: Cc: gtener@…
Operating System: MacOS X Architecture: Unknown/Multiple
Type of failure: Runtime crash Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

This is when trying to profile the QuickHull DPH benchmark. Without -debug we get assertion failures in the RTS heapCensus function. This is on OSX / x86, not sure if it's platform specific.

limitingfactor:dph-examples benl$ pwd
/Users/benl/devel/ghc/build/nightly/ghc-head/libraries/dph/dph-examples

limitingfactor:dph-examples benl$ ../../../inplace/bin/ghc-stage2 -Odph --make spectral/QuickHull/dph/Main.hs  \
  -package dph-prim-par -package dph-par -ispectral/QuickHull/dph \
  -ilib -ispectral/QuickHull/lib -rtsopts -threaded -debug -fforce-recomp

limitingfactor:dph-examples benl$ spectral/QuickHull/dph/Main 1000000 +RTS -DS -N4 -hT       
Main: internal error: ASSERTION FAILED: file rts/sm/Storage.c, line 640

    (GHC version 7.1.20101208 for i386_apple_darwin)
    Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug
Abort trap

Change History (8)

comment:1 Changed 9 years ago by simonmar

Milestone: 7.0.3
Owner: set to simonmar
Priority: normalhigh

Thanks, I'll take a look.

comment:2 Changed 9 years ago by simonmar

Not reproducible on 32-bit x86/Linux. Hmm, I'm not having much luck finding bugs I can fix today.

comment:3 Changed 9 years ago by simonmar

Operating System: Unknown/MultipleMacOS X

I also failed to reproduce it on x86_64/Linux with a validate build of today's HEAD.

comment:4 Changed 9 years ago by simonmar

Owner: changed from simonmar to igloo

Igloo is going to try reproducing it on OS X.

comment:5 Changed 9 years ago by igloo

Status: newinfoneeded

I got this error:

lib/Points2D/Types.hs:41:11:
    To use -XParallelArrays select a DPH backend with -fdph-par or -fdph-seq

After adding -fdph-par to the commandline, I can't reproduce the problem with the HEAD on OS X i386:

212:dph-examples ian$ spectral/QuickHull/dph/Main 1000000 +RTS -DS -N4 -hT
    a09f3540: cap 3: dph-examples: start timing
    a09f3540: cap 0: dph-examples: finished timing
elapsedTimeMS   = 1674
cpuTimeMS       = 2761

Ben, does it still fail for you?

comment:6 Changed 9 years ago by igloo

Owner: igloo deleted

comment:7 Changed 9 years ago by tener

Cc: gtener@… added
Version: 7.0.17.0.2

It's possibly related to this bug, but I'm not sure.

Today my program has just died with the following message:

textmining-zajecia04_05-zad1 +RTS -K100m -s -A30m -hT -N textmining-zajecia04_05-zad1: internal error: heapCensus, unknown object: 58

(GHC version 7.0.2 for x86_64_unknown_linux) Please report this as a GHC bug: http://www.haskell.org/ghc/reportabug

It fails reliably after doing ~30s of work, the '58' number stays the same in each run. The error goes away if I disable the -N switch OR -hT switch.

I'm runnign Linux, Arch Linux distro - up to date with LLVM 2.9, the building is -fllvm with a ton of flags.

comment:8 Changed 9 years ago by igloo

Resolution: worksforme
Status: infoneededclosed

I'll close this ticket.

Ben, please reopen if you can still reproduce this.

gtener, there's nothing we can do without a way to reproduce the problem, I'm afraid. If you can still reproduce it, please open a new ticket, including a testcase.

Note: See TracTickets for help on using tickets.