Opened 9 years ago

Closed 8 years ago

#4956 closed bug (worksforme)

threadDelay behavior 64-bit mac os x

Reported by: perikov Owned by:
Priority: normal Milestone: 7.2.1
Component: Compiler Version: 7.0.1
Keywords: threadDelay Cc: johan.tibell@…
Operating System: MacOS X Architecture: x86_64 (amd64)
Type of failure: Incorrect result at runtime Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description (last modified by igloo)

threadDelay 1000000

works as expected in 7.0.1-x86_64
return immediately in DEVELOPMENT 7.1.20110131
hangs eating CPU in STABLE 7.0.1.20110201, 7.0.1.20110211

to reproduce: fire up ghci

import Control.Concurrent
threadDelay 1000000

Change History (4)

comment:1 Changed 9 years ago by tibbe

Cc: johan.tibell@… added

comment:2 Changed 9 years ago by igloo

Description: modified (diff)

comment:3 Changed 9 years ago by igloo

Milestone: 7.2.1
Status: newinfoneeded

Can you still reproduce this? It seems to be working fine for me in 7.0.2 and HEAD:

Prelude Control.Concurrent Data.Time.Clock.POSIX> do getPOSIXTime >>= print; threadDelay 1000000; getPOSIXTime >>= print
1299355338.201281s
1299355339.201907s
Prelude Control.Concurrent Data.Time.Clock.POSIX> do getPOSIXTime >>= print; threadDelay 1000000; getPOSIXTime >>= print
1299355440.355244s
1299355441.355901s

comment:4 Changed 8 years ago by igloo

Resolution: worksforme
Status: infoneededclosed

No response from submitter, and worked for me.

Note: See TracTickets for help on using tickets.