Opened 9 years ago

Closed 9 years ago

#5049 closed bug (invalid)

GHC Panic on Text.Highlighting.Kate.Syntax.Ocaml

Reported by: Twey Owned by:
Priority: high Milestone: 7.2.1
Component: Compiler Version: 7.0.2
Keywords: panic expectJust constructSRT Cc:
Operating System: Linux Architecture: x86
Type of failure: Compile-time crash Test Case: highlighting-kate-0.2.9:Text.Highlighting.Kate.Syntax.Ocaml
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description (last modified by igloo)

[ 74 of 111] Compiling Text.Highlighting.Kate.Syntax.Ocaml ( Text/Highlighting/Kate/Syntax/Ocaml.hs, dist/build/Text/Highlighting/Kate/Syntax/Ocaml.o )
ghc: panic! (the 'impossible' happened)
  (GHC version 7.0.2 for i386-unknown-linux):
        expectJust constructSRT

Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug

cabal: Error: some packages failed to install:
highlighting-kate-0.2.9 failed during the building phase. The exception was:
ExitFailure 1

Change History (5)

comment:1 Changed 9 years ago by Twey

Seems to only occur with the Haskell Platform installed (from the Arch package, 2011.2.0.0-2.1); installing just ghc and cabal-install from packages then installing further dependencies with cabal-install works around the problem.

comment:2 Changed 9 years ago by simonmar

Milestone: 7.2.1
Priority: normalhigh
Type of failure: Runtime crashCompile-time crash

Maybe -dcore-lint would give more information?

comment:3 Changed 9 years ago by igloo

Description: modified (diff)

comment:4 Changed 9 years ago by igloo

Status: newinfoneeded

Twey, are you still able to reproduce this? If so, what does it say if you add -dcore-lint to the GHC flags?

comment:5 Changed 9 years ago by igloo

Resolution: invalid
Status: infoneededclosed

No response from submitter, so closing.

Note: See TracTickets for help on using tickets.