Opened 9 years ago

Closed 8 years ago

#5090 closed bug (worksforme)

print026 sporadically fails

Reported by: ezyang Owned by: igloo
Priority: normal Milestone: 7.2.1
Component: Compiler Version: 7.1
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

It seems to still be the case that print026 sporadically fails:

=====> print026(ghci) 25 of 74 [0, 0, 0]
cd . && HC='/home/ezyang/Dev/ghc-build-master/inplace/bin/ghc-stage2' HC_OPTS='-dcore-lint -dcmm-lint -dno-debug-output -no-user-package-conf -rtsopts  ' '/home/ezyang/Dev/ghc-build-master/inplace/bin/ghc-stage2' --interactive -v0 -ignore-dot-ghci -dcore-lint -dcmm-lint -dno-debug-output -no-user-package-conf -rtsopts   -ignore-dot-ghci   <print026.script >print026.run.stdout 2>print026.run.stderr
Actual stdout output differs from expected:
--- ./print026.stdout.normalised	2011-04-04 16:58:58.000000000 +0100
+++ ./print026.run.stdout.normalised	2011-04-04 16:58:58.000000000 +0100
@@ -1,7 +1,4 @@
 fromList "abc"
-l = Data.Sequence.Seq (Data.Sequence.Deep 3
-                                          (Data.Sequence.One (Data.Sequence.Elem 'a'))
-                                          Data.Sequence.Empty
-                                          (Data.Sequence.Two (Data.Sequence.Elem 'b')
-                                                             (Data.Sequence.Elem 'c')))
+l = <Data.Sequence.Deep> (<Data.Sequence.One> 'a')
+                         <Data.Sequence.Empty> (<Data.Sequence.Two> 'b' 'c')
 l = fromList "abc"
*** unexpected failure for print026(ghci)

I saw this commit by Ian a while back:

commit 5e95d99276e754a12279b909ab6365c262e80da1
Author: Ian Lynagh <igloo@earth.li>
Date:   Mon Jun 2 20:41:13 2008 +0000

    Skip print026 in the 6.8 branch
    It fails for me, but not consistently - possibly only with a validate
    build. Seems plausible that the problem is something like library build
    flags.
    
    -l = Data.Sequence.Seq (Data.Sequence.Deep 3
    -                                          (Data.Sequence.One (Data.Sequence.Elem 'a')) Data.Sequence.Empty
    -                                          (Data.Sequence.Two (Data.Sequence.Elem 'b') (Data.Sequence.Elem 'c')))
    +l = <Data.Sequence.Deep> (<Data.Sequence.One> 'a') <Data.Sequence.Empty>
    +                         (<Data.Sequence.Two> 'b' 'c')

So this is probably not some deep bug, but we ought fix up the test case to work in all cases. (I can't tell if this is a containers problem or a GHC problem.)

Change History (3)

comment:1 Changed 9 years ago by igloo

Milestone: 7.2.1
Owner: set to igloo

comment:2 Changed 9 years ago by igloo

Status: newinfoneeded

I can't get this to fail with a validate build.

What platform are you on?

Are you seeing the failures with regular validate builds?

comment:3 Changed 8 years ago by igloo

Resolution: worksforme
Status: infoneededclosed

No response from submitter

Note: See TracTickets for help on using tickets.