Opened 9 years ago

Closed 8 years ago

#5169 closed feature request (fixed)

LLVM backend should warn if llvm tools aren't installed

Reported by: dterei Owned by: dterei
Priority: normal Milestone:
Component: Compiler (LLVM) Version: 7.0.3
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Other Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

At the moment the LLVM backend just assumes that the various LLVM tools will be available on the command line. It never checks for this and so if you try to compile some code using the LLVM backend without LLVM tools available on the command line then it fails with:

cannot run: opt

We should print something more informative.

Change History (3)

comment:1 Changed 9 years ago by dterei

Owner: set to dterei

comment:2 Changed 9 years ago by dterei

Component: CompilerCompiler (LLVM)
Type of failure: None/UnknownOther

comment:3 Changed 8 years ago by dterei

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.