Opened 9 years ago

Closed 9 years ago

#5215 closed bug (fixed)

process library does not build with GHC 7.0.x

Reported by: Favonia Owned by: simonmar
Priority: normal Milestone: 7.2.1
Component: libraries/process Version: 7.0.3
Keywords: interruptible waitForProcess Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Building GHC failed Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

The process library in the trunk does not build with GHC 7.0.x. The reason is that GHC 7.0.x does not seem to support the "interruptible" FFI calls, but the macro asserts that GHC 7 supports it.

People on #ghc (thanks to thoughtpolice) have confirmed that GHC 7.1.x supports it. I hereby propose a patch to bump the version check from 700 to 710.

Attachments (1)

0001-GHC-7.0.x-has-not-supported-interruptible-FFI-yet.patch (805 bytes) - added by Favonia 9 years ago.
patch to System/Process.hs (fixed)

Download all attachments as: .zip

Change History (3)

comment:1 Changed 9 years ago by simonmar

Milestone: 7.2.1
Owner: changed from Favonia to simonmar

Thanks, your patch was not quite right (710 should be 701), but I'll fix and commit.

Changed 9 years ago by Favonia

patch to System/Process.hs (fixed)

comment:2 Changed 9 years ago by simonmar

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.