Opened 9 years ago

Closed 8 years ago

#5304 closed bug (fixed)

Core lint failure in stage 3 build

Reported by: simonmar Owned by:
Priority: highest Milestone: 7.2.1
Component: Compiler Version: 7.1
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

A stage 3 build is currently failing with a Core Lint error:

"inplace/bin/ghc-stage2"   -H32m -O     -package-name ghc-7.1.20110630 -hide-all-packages -i -icompiler/basicTypes -icompiler/cmm -icompiler/codeGen -icompiler/coreSyn -icompiler/deSugar -icompiler/ghci -icompiler/hsSyn -icompiler/iface -icompiler/llvmGen -icompiler/main -icompiler/nativeGen -icompiler/parser -icompiler/prelude -icompiler/profiling -icompiler/rename -icompiler/simplCore -icompiler/simplStg -icompiler/specialise -icompiler/stgSyn -icompiler/stranal -icompiler/typecheck -icompiler/types -icompiler/utils -icompiler/vectorise -icompiler/stage3/build -icompiler/stage3/build/autogen -Icompiler/stage3/build -Icompiler/stage3/build/autogen -Icompiler/../libffi/build/include -Icompiler/stage2 -Icompiler/../libraries/base/cbits -Icompiler/../libraries/base/include -Icompiler/. -Icompiler/parser -Icompiler/utils   -optP-DGHCI -optP-include -optPcompiler/stage3/build/autogen/cabal_macros.h -package Cabal-1.11.0 -package array-0.3.0.2 -package base-4.3.1.0 -package bin-package-db-0.0.0.0 -package bytestring-0.9.2.0 -package containers-0.4.0.0 -package directory-1.1.0.0 -package filepath-1.2.0.0 -package hoopl-3.8.7.0 -package hpc-0.5.0.6 -package old-time-1.0.0.6 -package process-1.0.1.4 -package template-haskell-2.5.0.0 -package unix-2.4.1.0  -Wall -fno-warn-name-shadowing -fno-warn-orphans -XHaskell98 -XNondecreasingIndentation -XCPP -XMagicHash -XUnboxedTuples -XPatternGuards -XForeignFunctionInterface -XEmptyDataDecls -XTypeSynonymInstances -XMultiParamTypeClasses -XFlexibleInstances -XRank2Types -XScopedTypeVariables -XDeriveDataTypeable -DGHCI_TABLES_NEXT_TO_CODE -DSTAGE=3 -H64m -O -fasm -DDEBUG -dcore-lint -debug +RTS -c -RTS -no-user-package-conf -rtsopts     -odir compiler/stage3/build -hidir compiler/stage3/build -stubdir compiler/stage3/build -hisuf hi -osuf  o -hcsuf hc -c compiler/hsSyn/HsExpr.lhs -o compiler/stage3/build/HsExpr.o
*** Core Lint errors : in result of Simplifier SimplMode {Phase = 0 [final],
                                                          inline,
                                                          rules,
                                                          eta-expand,
                                                          case-of-case} max-iterations=4 ***
<no location info>:
    [RHS of lvl_s6KV :: GHC.Real.Rational
                        -> HsExpr.HsExpr Name.Name -> Outputable.SDoc]
    Demand type has  2  arguments, rhs has  1 arguments,  lvl_s6KV
    Binder's strictness signature: DmdType AS

Change History (3)

comment:1 Changed 9 years ago by simonmar

This appears to have gone away in the latest builds, but we can recreate the failing state with this fingerprint (from the last failure on 6/7/2011):

Respository hashes:
.|e49dae36a00b2af8f6ad583dd24f9bacf5711242
ghc-tarballs|e7b7b152083f7c3e3559e557a239757d41ac02a6
libraries/Cabal|bc794b750d844b2b4716c6d25627cd0dd051e374
libraries/Win32|47e101a9c8acec12a4e07fa4fa1dc6337dfcc19c
libraries/array|e4b4e2e0a79f4138bdff4f10d263436b0155f449
libraries/base|48546e804c56ac87e222547326b48e6df94bc744
libraries/binary|9065df2120254601c68c3a28264fd062abde9354
libraries/bytestring|3b432859b4062561fa9478e4a171b22c6c3f0915
libraries/containers|3e718c1eb3c4f72adf616ec212856cc40b1803a6
libraries/directory|3a0f2e2cb94c3e4f346023acc7201409d2876ed8
libraries/dph|80b5cf89fecc13b20234082ab9f7a1deec164409
libraries/extensible-exceptions|a667b48d0cb6469b6611cb516d16836aa002e782
libraries/filepath|92d211a2752fe8827582ae0d97efd18722ad3d87
libraries/ghc-prim|bca02fda94c406cc484a3bfbcb6d120d43439935
libraries/haskeline|0adbe5783d7cd121c314a8a3dd450a250d99b10c
libraries/haskell2010|72baf1ec30a09b7b40dda244cd4dc588790da862
libraries/haskell98|2d8b00074746367327134c989de781a794c6072d
libraries/hoopl|0febb7f04ff4326bd120fc75549845e5e9678d72
libraries/hpc|fce8babbc3f60fb195d84545753dc342422ab8e1
libraries/integer-gmp|2567c97aaa467cb676a6ecc2cf840c92ee1cb6ec
libraries/integer-simple|c3e9c0268b4d59895829e429d1ac767e6041b06a
libraries/mtl|a748dfa2770af1d348dfaa8ad6955b25b4935711
libraries/old-locale|7f09f55ea3011c17c526805f099394a05ec9c3fe
libraries/old-time|2cebe05be7304c813b7edc29ca583b32a7b7c879
libraries/pretty|e00aa7e0f82fc6f13ad85f1b3a27f53efe473e60
libraries/primitive|8057ba8cf108813eddc5f565b6ee6b6dde827c34
libraries/process|fa5db2b9bd85d951579447876cc82220b8fb5a0b
libraries/random|628021146f6890d41175cc2eafc3da120da11948
libraries/template-haskell|acd4c3292d0f7a222a1f4f426054e4732a809fc8
libraries/terminfo|f4476f1881085b74dbe65cf4a4561e8fb34017d4
libraries/unix|ccbd92a265c98ab1119adfe83f0cd5c595fe7a59
libraries/utf8-string|d28cd1fbd4ebaaa0608c070bd02ed72dc9b70399
libraries/vector|aee660636a705d7cb1a082b032fb90e7fafbcf71
libraries/xhtml|9a4d7d64d0491a1844d5b5759275b029ccd1e2cd
nofib|7b931b2412ec15575fb9898913ecd08079ff5e15
testsuite|5f0f9c1c8cdfea26fe4da118b29ba33c3548a31b
utils/haddock|5ca76f4fdf9a9ff38983e4f0f794eac11f98594a
utils/hsc2hs|c46eed44ce96f1719334ffb190eddf63695bc553

comment:2 Changed 9 years ago by simonpj

Status: newmerge

I have reason to believe I have fixed this, with

commit 0971055c2745b0cb2e167167ceb7a614ea5f8aca
Author: Simon Peyton Jones <simonpj@microsoft.com>
Date:   Thu Jul 21 12:54:51 2011 +0100

    Eta expand partial applications
    
    When we have
         x = \v -> map g
    we want to eta-expand to
         x = \v y -> map g y
    
    We weren't doing so, and that led to worse code and,
    perhaps, #5285.  I need to check the latter, but I
    was certainly seeing one similar error.  Anyway
    this looks like a definite improvement

It's so painful to reproduce the original that I'm just going to close and hope.

pls merge though

Simon

comment:3 Changed 8 years ago by igloo

Resolution: fixed
Status: mergeclosed
Note: See TracTickets for help on using tickets.