Opened 8 years ago

Closed 8 years ago

#5360 closed bug (fixed)

vectorise error building dph

Reported by: daniel.is.fischer Owned by:
Priority: highest Milestone: 7.4.1
Component: Compiler Version: 7.3
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

validate fails to build (on x86 linux and x86_64 linux):

"inplace/bin/ghc-stage2"   -H32m -O -Wall -Werror -H64m -O0
    -package-name dph-seq-0.5 -hide-all-packages -i
 -ilibraries/dph/dph-seq/../dph-common
 -ilibraries/dph/dph-seq/dist-install/build
 -ilibraries/dph/dph-seq/dist-install/build/autogen
 -Ilibraries/dph/dph-seq/dist-install/build
 -Ilibraries/dph/dph-seq/dist-install/build/autogen
 -Ilibraries/dph/dph-seq/.    -optP-include
 -optPlibraries/dph/dph-seq/dist-install/build/autogen/cabal_macros.h
 -package array-0.3.0.3 -package base-4.4.0.0 -package dph-base-0.5
 -package dph-prim-seq-0.5 -package ghc-7.3.20110730
 -package ghc-prim-0.2.0.0 -package random-1.0.0.4
 -package template-haskell-2.6.0.0  -Odph -funbox-strict-fields
 -fcpr-off -fdph-this -package-name dph-seq -XHaskell98
 -XTypeFamilies -XGADTs -XRankNTypes -XBangPatterns -XMagicHash
 -XUnboxedTuples -XTypeOperators -O2 -O -dcore-lint
 -fno-warn-deprecated-flags -no-user-package-conf -rtsopts
 -Wwarn    -odir libraries/dph/dph-seq/dist-install/build
 -hidir libraries/dph/dph-seq/dist-install/build
 -stubdir libraries/dph/dph-seq/dist-install/build
 -hisuf hi -osuf  o -hcsuf hc -c
 libraries/dph/dph-seq/../dph-common/Data/Array/Parallel.hs
 -o libraries/dph/dph-seq/dist-install/build/Data/Array/Parallel.o
*** Vectorisation error ***
    Type mismatch in vectorisation pragma for Data.Array.Parallel.unzipP
        Expected type forall a_a1SF b_a1SG.
                      (Data.Array.Parallel.PArray.PRepr.PA a_a1SF,
                       Data.Array.Parallel.PArray.PRepr.PA b_a1SG) =>
                      Data.Array.Parallel.PArray.Base.PArray (a_a1SF, b_a1SG)
                      Data.Array.Parallel.Lifted.Closure.:-> (Data.Array.Parallel.PArray.Base.PArray
                                                                a_a1SF,
                                                              Data.Array.Parallel.PArray.Base.PArray
                                                                b_a1SG)
        Inferred type forall a_a21g b_a21h.
                      (Data.Array.Parallel.PArray.PRepr.PA b_a21h,
                       Data.Array.Parallel.PArray.PRepr.PA a_a21g) =>
                      Data.Array.Parallel.PArray.Base.PArray (a_a21g, b_a21h)
                      Data.Array.Parallel.Lifted.Closure.:-> (Data.Array.Parallel.PArray.Base.PArray
                                                                a_a21g,
                                                              Data.Array.Parallel.PArray.Base.PArray
                                                                b_a21h)
gmake[1]: *** [libraries/dph/dph-seq/dist-install/build/Data/Array/Parallel.o] Fehler 1
gmake: *** [all] Fehler 2

I doubt it's dph's fault, though, since it built yesterday morning and apparently there have been no changes to dph for several days. I didn't find any commits to ghc mentioning vectorisation recently either, so I've no idea what may have caused it.

Attachments (2)

0001-Revert-Error-message-wibbles.patch (5.2 KB) - added by daniel.is.fischer 8 years ago.
Revert some error message changes
0002-Adjust-expected-stderr-for-T3234.patch (1.1 KB) - added by daniel.is.fischer 8 years ago.
This change was not caused by UniqFM but part of the same commit

Download all attachments as: .zip

Change History (16)

comment:1 Changed 8 years ago by igloo

Milestone: 7.4.1
Priority: normalhighest

comment:2 Changed 8 years ago by igloo@…

commit e44c591cac5aba8c7718261275db925bc2db9753

Author: Ian Lynagh <igloo@earth.li>
Date:   Sat Jul 30 16:56:26 2011 +0100

    Don't build dph for now: it doesn't work (#5360)

 ghc.mk   |    8 +++++---
 validate |    4 +++-
 2 files changed, 8 insertions(+), 4 deletions(-)

comment:3 Changed 8 years ago by ezyang

adc3fb884bc53d229faf9f599fb3f890cadeccb1 is known to work, if you're bisecting.

comment:4 Changed 8 years ago by daniel.is.fischer

git bisect located the dph breakage at bf5af91ca597666641b8519abc85a31297b30823, dph built with e1f013cc59347a727dd285841c8986051aea3e36. Seems to be different behaviour of UniqFM vs. Map.

By the way, e44c591cac5aba8c7718261275db925bc2db9753 didn't work for me, I needed to comment out the "libraries/dph" line in packages too.

comment:5 Changed 8 years ago by ezyang

Yeah, I'm seeing this failure now:

"inplace/bin/ghc-stage1"   -H64m -O -fasm    -package-name base-4.4.0.0 -hide-all-packages -i -ilibraries/base/. -ilibraries/base/dist-install/build -ilibraries/base/dist-install/build/autogen -Ilibraries/base/dist-install/build -Ilibraries/base/dist-install/build/autogen -Ilibraries/base/include   -optP-DOPTIMISE_INTEGER_GCD_LCM -optP-include -optPlibraries/base/dist-install/build/autogen/cabal_macros.h -package ghc-prim-0.2.0.0 -package integer-gmp-0.3.0.0 -package rts-1.0  -package-name base -XHaskell98 -XCPP -O -dcore-lint -no-user-package-conf -rtsopts     -odir libraries/base/dist-install/build -hidir libraries/base/dist-install/build -stubdir libraries/base/dist-install/build -hisuf hi -osuf  o -hcsuf hc -c libraries/base/./GHC/Num.lhs -o libraries/base/dist-install/build/GHC/Num.o
GHC error in desugarer lookup in base:GHC.Num:
  Can't find interface-file declaration for variable GHC.Integer.Type.smallInteger
    Probable cause: bug in .hi-boot file, or inconsistent .hi file
    Use -ddump-if-trace to get an idea of which file caused the error
ghc-stage1: panic! (the 'impossible' happened)
  (GHC version 7.3 for i386-unknown-linux):
	initDs IOEnv failure

comment:6 Changed 8 years ago by igloo@…

commit 2ad66b597b139ea73830f2aedf564df2b72960e9

Author: Ian Lynagh <igloo@earth.li>
Date:   Sun Jul 31 01:45:57 2011 +0100

    Fix the workaround for #5360
    
    The build still wasn't going through if you had libraries/dph in your tree.

 packages |    3 ++-
 1 files changed, 2 insertions(+), 1 deletions(-)

comment:7 Changed 8 years ago by chak

As SimonPJ wrote in the email that Ian linked to in the first comment. This is due to an interaction of the vectoriser with the type checker. A fix is incoming. (I still need to run it through validate.)

comment:8 Changed 8 years ago by chak@…

commit b4a01788a1a833de64cba041c796fa35e0275220

Author: Manuel M T Chakravarty <chak@cse.unsw.edu.au>
Date:   Sun Jul 31 17:37:38 2011 +1000

    Revert "Don't build dph for now: it doesn't work (#5360)"
    
    This reverts commit e44c591cac5aba8c7718261275db925bc2db9753.

 ghc.mk   |    8 +++-----
 validate |    4 +---
 2 files changed, 4 insertions(+), 8 deletions(-)

comment:9 Changed 8 years ago by chak@…

commit 4b42e7298fbcdbde60182723e3bf503e2a5c2f99

Author: Manuel M T Chakravarty <chak@cse.unsw.edu.au>
Date:   Sun Jul 31 17:37:23 2011 +1000

    Revert "Fix the workaround for #5360"
    
    This reverts commit 2ad66b597b139ea73830f2aedf564df2b72960e9.

 packages |    3 +--
 1 files changed, 1 insertions(+), 2 deletions(-)

comment:10 Changed 8 years ago by chak

Resolution: fixed
Status: newclosed

Fixed by

commit 5ff42f08320838a1000a525d4d9d98a5b370f77f
Author: Manuel M T Chakravarty <chak@cse.unsw.edu.au>
Date:   Sun Jul 31 17:29:39 2011 +1000

   Fix the use of UniqueFM in the type checker (commit bf5af91ca597666641b8519abc85a31297b30823) to preserve the ordering of contexts

   See also http://www.haskell.org/pipermail/cvs-ghc/2011-July/064550.html

I also reverted the commits disabling DPH.

comment:11 Changed 8 years ago by daniel.is.fischer

Resolution: fixed
Status: closednew

Reopening since a few expected error messages in the testsuite have to be reset to the state before the Map/UniqFM switch.

Changed 8 years ago by daniel.is.fischer

Revert some error message changes

Changed 8 years ago by daniel.is.fischer

This change was not caused by UniqFM but part of the same commit

comment:12 Changed 8 years ago by daniel.is.fischer

Status: newpatch

Patches for the error messages.

comment:13 Changed 8 years ago by daniel.is.fischer

Oops, didn't expect reopening would maintain highest priority, sorry.

comment:14 Changed 8 years ago by daniel.is.fischer

Resolution: fixed
Status: patchclosed
Note: See TracTickets for help on using tickets.