Opened 8 years ago

Closed 8 years ago

#5394 closed bug (worksforme)

GHC hangs on compile of anything

Reported by: beezir Owned by:
Priority: high Milestone: 7.4.1
Component: Compiler Version: 7.0.3
Keywords: Cc:
Operating System: Windows Architecture: x86_64 (amd64)
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description (last modified by igloo)

I'm probably doing something wrong, but I have a fresh install of Haskell Platform 2011.2.0.1 which includes GHC version 7.0.3. Under Windows 7 x64, I can not get it to compile even the simplest program without hanging. The source I am compiling is as follows:

main = putStrLn "Hello, world!"

ghc --make helloWorld.hs hangs here:

[1 of 1] Compiling Main             ( helloWorld.hs, helloWorld.o )

It never exits even if left for hours. Attempting compile with -v gives the following and then hangs:

Glasgow Haskell Compiler, Version 7.0.3, for Haskell 98, stage 2 booted by GHC version 6.12.2
Using binary package database: C:\Program Files (x86)\Haskell Platform\2011.2.0.1\lib\package.conf.d\package.cache
wired-in package ghc-prim mapped to ghc-prim-0.2.0.0-e1f7c380581d61d42b0360d440cc35ed
wired-in package integer-gmp mapped to integer-gmp-0.2.0.3-91607778cf3ae8f3948a50062b4f8479
wired-in package base mapped to base-4.3.1.0-f520cd232cc386346843c4a12b63f44b
wired-in package rts mapped to builtin_rts
wired-in package template-haskell mapped to template-haskell-2.5.0.0-7d9b1443ac5ab69e5ed705a487990deb
wired-in package dph-seq not found.
wired-in package dph-par not found.
Hsc static flags: -static
*** Chasing dependencies:
Chasing modules from: *helloWorld.hs
Stable obj: []
Stable BCO: []
Ready for upsweep
  [NONREC
      ModSummary {
         ms_hs_date = Mon Aug  8 19:21:29 Eastern Daylight Time 2011
         ms_mod = main:Main,
         ms_imps = [import Prelude]
         ms_srcimps = []
      }]
compile: input file helloWorld.hs
Created temporary directory: C:\Users\Dave\AppData\Local\Temp\ghc6464_0
*** Checking old interface for main:Main:
[1 of 1] Compiling Main             ( helloWorld.hs, helloWorld.o )
*** Parser:
*** Renamer/typechecker:
*** Desugar:
    Result size = 8
*** Simplifier SimplMode {Phase = 0 [final],
                      inline,
                      no rules,
                      eta-expand,
                      case-of-case} max-iterations=4:
    Result size = 8
*** Tidy Core:
    Result size = 8

Change History (7)

comment:1 Changed 8 years ago by beezir

Sorry for the formatting, I'm new at this. Turns out moving it out of the "My Documents" subfolder fixed the problem, so I'm assuming this had something to do with the space in the directory name?

comment:2 Changed 8 years ago by simonmar

Spaces in the directory name should be fine. But at least we have a clue to reproduce the problem: install GHC under "My Documents".

comment:3 Changed 8 years ago by igloo

Description: modified (diff)

comment:4 Changed 8 years ago by igloo

Milestone: 7.4.1
Priority: normalhigh

I can't reproduce it on Linux.

comment:5 Changed 8 years ago by igloo

Owner: set to igloo

comment:6 Changed 8 years ago by igloo

difficulty: Unknown
Owner: igloo deleted

I can't reproduce this on 64bit Windows 7 either, with both the compiler and the source file under c:/Documents and Settings/ian/My Documents/5394/.

Tried in cygwin, msys, and cmd.

comment:7 Changed 8 years ago by simonmar

Resolution: worksforme
Status: newclosed

Lacking a way to reproduce it, let's close pending more information.

Note: See TracTickets for help on using tickets.