Opened 8 years ago

Closed 8 years ago

#5707 closed bug (fixed)

internal error: Invalid object in processHeapClosureForDead(): 0

Reported by: brinchj Owned by:
Priority: lowest Milestone: 7.4.1
Component: Compiler Version: 7.2.1
Keywords: biographical profiling Cc:
Operating System: Linux Architecture: x86_64 (amd64)
Type of failure: Runtime crash Test Case:
Blocked By: Blocking:
Related Tickets: 5451, 1519 Differential Rev(s):
Wiki Page:

Description

I can't figure out if this has been fixed in 7.3 .. anyway, better safe than sorry, so here goes.

I get this error with biographical profiling (like #5451 and #1519, i guess). It's present in both 7.2.1 and 7.2.2 - haven't tried 7.3 or 7.4.

Just let me know if this is a fixed issue or not, and I'll see if I can provide a test case (it's not a completely trivial I'm trying to profile program).

Change History (8)

comment:1 Changed 8 years ago by brinchj

Operating System: Unknown/MultipleLinux
Type of failure: None/UnknownRuntime crash

comment:2 Changed 8 years ago by simonmar

difficulty: Unknown
Status: newinfoneeded

I don't know if your issue is fixed or not. If you could try with the 7.4 RC (due out soon) that would be great, otherwise please attach a test case and we'll look into it.

comment:3 Changed 8 years ago by brinchj

If ghc 7.4 rc is out soon, i'll give it a go and see if it works. Right now, I can't run the 7.4 due to a configuration error when installing the enumerator package:

jos@laptux code/next ±master⚡ > cabal install enumerator Resolving dependencies... cabal: cannot configure text-0.11.1.9. It requires integer-gmp >=0.2 && <0.4 There is no available version of integer-gmp that satisfies >=0.2 && <0.4

Regarding a small test case, I don't really know where to start. The project currently contains about 50 haskell modules, and I have no clue as to what part could cause the problem.

There's a lot of IO going on, and the system is doing a bit of forkIO as well, running in several isolated lightweight threads.

The error is triggered by the rts option -hb. Other options, like -hc or -p works. Btw, the exit code produced is 134.

comment:4 Changed 8 years ago by brinchj

Riiight, the threads aren't really isolated, but they communicate solely using STM and TChan/TMvar.

comment:5 Changed 8 years ago by simonmar

The test case doesn't have to be small, as long as it is reproducible and you can give us the source code.

comment:6 Changed 8 years ago by igloo

Milestone: 7.4.2
Priority: normallowest

comment:7 Changed 8 years ago by brinchj

I installed the 7.4 RC and it seems to have been fixed (7.4.0.20120108). Thanks a lot! :)

comment:8 Changed 8 years ago by igloo

Milestone: 7.4.27.4.1
Resolution: fixed
Status: infoneededclosed

Thanks for letting us know!

Note: See TracTickets for help on using tickets.