Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#5774 closed bug (duplicate)

main = forever (putStrLn =<< getLine) continuously saturates a CPU when compiled

Reported by: lpsmith Owned by:
Priority: normal Milestone:
Component: Compiler Version: 7.4.1-rc1
Keywords: Cc:
Operating System: Linux Architecture: x86_64 (amd64)
Type of failure: Runtime performance bug Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

$ ghc --make copycat.hs
$ ./copycat

Attachments (1)

copycat.hs (74 bytes) - added by lpsmith 8 years ago.

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by lpsmith

Attachment: copycat.hs added

comment:1 Changed 8 years ago by igloo

difficulty: Unknown
Resolution: duplicate
Status: newclosed

Duplicate of #5773.

comment:2 Changed 8 years ago by simonpj

Ian, are you sure it's a dup? The symptoms look very different. Have you checked that it's ok in 7.4?

Simon

comment:3 Changed 8 years ago by simonpj

Ignore me. I was looking at #5373 or something

Note: See TracTickets for help on using tickets.