Opened 7 years ago

Closed 7 years ago

#7262 closed bug (fixed)

directory 1.2 fails to build with base < 4.6

Reported by: sopvop Owned by: igloo
Priority: high Milestone: 7.6.2
Component: libraries/directory Version: 7.4.2
Keywords: Cc: bjp@…
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

Old base still has try and catch in Prelude and System.IO.Error which results in ambiguity.

Attachments (2)

fix_build.patch (3.2 KB) - added by sopvop 7 years ago.
fix_build.2.patch (3.7 KB) - added by sopvop 7 years ago.

Download all attachments as: .zip

Change History (8)

Changed 7 years ago by sopvop

Attachment: fix_build.patch added

comment:1 Changed 7 years ago by bjp

Cc: bjp@… added

Changed 7 years ago by sopvop

Attachment: fix_build.2.patch added

comment:2 Changed 7 years ago by sopvop

Second patch allows directory to be build even on ghc-7.0.3.

comment:3 Changed 7 years ago by akaspin

Any chances to get patched on hackage? Or revert to previous? It's serious bug.

comment:4 Changed 7 years ago by sopvop

Status: newpatch

comment:5 Changed 7 years ago by simonmar

difficulty: Unknown
Milestone: 7.6.2
Owner: set to igloo
Priority: normalhigh

Ian, could you look into this please?

comment:6 Changed 7 years ago by igloo

Resolution: fixed
Status: patchclosed

Thanks for the patch; I've applied it and uploaded 1.2.0.1 to Hackage.

Note: See TracTickets for help on using tickets.