Opened 7 years ago

Closed 7 years ago

Last modified 3 years ago

#7422 closed bug (duplicate)

GHC panics while trying to derive Generic for GADT with kind-lifted phantom parameter

Reported by: rpglover64 Owned by:
Priority: normal Milestone:
Component: Compiler Version: 7.4.1
Keywords: Generics Cc:
Operating System: MacOS X Architecture: x86
Type of failure: Compile-time crash Test Case: polykinds/T7422
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

This may be a duplicate of #5884

Compiling the attached file gives the following crash:

ghc: panic! (the 'impossible' happened)
  (GHC version 7.4.1 for i386-apple-darwin):
        tcTyVarDetails ( tag{tv ae8} [tv] :: main:Main.ExprTag{tc rdD} )

Attachments (1)

baz.hs (343 bytes) - added by rpglover64 7 years ago.

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by rpglover64

Attachment: baz.hs added

comment:1 Changed 7 years ago by dreixel

Resolution: duplicate
Status: newclosed

Thanks for the report, but your code compiles in 7.6.1. Might have been fixed with #5936.

(Note that I haven't thought about what you can actually do with GADTs in GHC.Generics; so far I'm just trying to make sure the compiler doesn't crash.)

comment:2 Changed 7 years ago by simonpj

difficulty: Unknown
Test Case: polykinds/T7422

I've added a regression test to be on the safe side.

Simon

comment:3 Changed 3 years ago by RyanGlScott

Keywords: Generics added
Note: See TracTickets for help on using tickets.