Opened 6 years ago

Closed 6 years ago

#8273 closed bug (duplicate)

ghc: panic! (the 'impossible' happened)

Reported by: ready2go Owned by:
Priority: normal Milestone:
Component: Compiler Version: 7.4.1
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: x86_64 (amd64)
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: #5961; #8163 Differential Rev(s):
Wiki Page:

Description (last modified by jstolarek)

Prelude>  data Shape = Circle Float Float Float | Rectangle Float Float Float Float deriving (show)
ghc: panic! (the 'impossible' happened)
  (GHC version 7.4.1 for x86_64-unknown-linux):
	nameModule show{tv a9J}

Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug

My Apologies if this is a duplicate, first time I have used trac, or this system- reproduced fault twice from fresh start of GHCi it twice on my Ubuntu 12.04 LTS system, using Haskell platform from Ubuntu repository

Change History (3)

comment:1 Changed 6 years ago by ready2go

The problem is triggered by my typing 'show' with a lower-case 'S' by newbie mistake in 'deriving(Show)'

comment:2 Changed 6 years ago by jstolarek

Description: modified (diff)

comment:3 Changed 6 years ago by jstolarek

Resolution: duplicate
Status: newclosed
Test Case: Prelude> data Shape = Circle Float Float Float | Rectangle Float Float Float Float deriving (show)

This is already solved in HEAD. Thanks for reporting.

Note: See TracTickets for help on using tickets.