Opened 6 years ago

Closed 6 years ago

#8328 closed bug (duplicate)

Crash at -O2: Cannot read from uninitialized register

Reported by: bos Owned by:
Priority: highest Milestone: 7.8.1
Component: Compiler Version: 7.7
Keywords: Cc:
Operating System: Linux Architecture: x86_64 (amd64)
Type of failure: Compile-time crash Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

I did a quick x86_64 compile of all of Hackage today using HEAD, and GHC is crashing when compiling the utf8-string package.

[2 of 7] Compiling Codec.Binary.UTF8.Generic ( Codec/Binary/UTF8/Generic.hs, dist/dist-sandbox-4a6171fb/build/Codec/Binary/UTF8/Generic.o )
ghc: panic! (the 'impossible' happened)
  (GHC version 7.7.20130915 for x86_64-unknown-linux):
        allocateRegsAndSpill: Cannot read from uninitialized register
    %vI_sa0l

To reproduce using utf8-string:

cabal get utf8-string
cd utf8-string*
ghc -XCPP -fforce-recomp -O2 --make -c Codec/Binary/UTF8/Generic.hs

Change History (1)

comment:1 Changed 6 years ago by bos

Resolution: duplicate
Status: newclosed

Duplicate of #7574.

Note: See TracTickets for help on using tickets.