Opened 6 years ago

Closed 6 years ago

#8775 closed bug (duplicate)

GHC panic building postgresql-simple

Reported by: r0ml Owned by:
Priority: normal Milestone:
Component: Compiler Version: 7.8.1-rc1
Keywords: Cc:
Operating System: MacOS X Architecture: x86_64 (amd64)
Type of failure: Other Test Case:
Blocked By: Blocking:
Related Tickets: #8743 Differential Rev(s):
Wiki Page:

Description

For:

cabal install postgresql-simple

(for all versions of postgresql-simple since 0.3) on OSX Mavericks, I get the following:

[14 of 32] Compiling Database.PostgreSQL.Simple.ToRow ( src/Database/PostgreSQL/Simple/ToRow.hs, dist/build/Database/PostgreSQL/Simple/ToRow.o ) ghc: panic! (the 'impossible' happened)

(GHC version 7.8.20140130 for x86_64-apple-darwin):

Prelude.(!!): index too large

Please report this as a GHC bug: http://www.haskell.org/ghc/reportabug

This also failed to build with 7.6.3 for different reasons -- hence I installed and attempted 7.8.1 -- but the failure was more spectacular.

Change History (1)

comment:1 Changed 6 years ago by rwbarton

Resolution: duplicate
Status: newclosed

Thanks for the report, but this is a duplicate of #8743.

Note: See TracTickets for help on using tickets.