Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#8941 closed bug (fixed)

Module that causes GHC-7.8 to exhaust memory when compiled with -O2

Reported by: guest Owned by:
Priority: normal Milestone:
Component: Compiler Version: 7.8.1-rc2
Keywords: Cc:
Operating System: Linux Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

The module is JSON.Render in http://src.seereason.com/o2bug. When compiled ghc uses up at least 16GB of RAM and then dies. I haven't been able to simplify it very much, almost any change to JSON.Render causes it to start working properly. I did get it to fail using only packages available in hackage.

Change History (9)

comment:1 Changed 5 years ago by guest

Summary: Module that causes GHC-7.8 to exhaust memory compiled with -O2Module that causes GHC-7.8 to exhaust memory when compiled with -O2

comment:2 Changed 5 years ago by gidyn

Cc: gideon@… added

comment:3 Changed 5 years ago by guest

Cc: marco.vax91@… added

comment:4 Changed 5 years ago by bjp

I had a similar problem one month ago and believe that it is caused by https://ghc.haskell.org/trac/ghc/ticket/7068 in my case.

I temporarily fixed it by adding a -fno-spec-constr option, maybe you want to try that as well?

comment:5 Changed 5 years ago by guest

I will give that a try.

comment:6 Changed 5 years ago by jwlato

Cc: jwlato@… added

comment:7 Changed 5 years ago by simonpj

Status: newinfoneeded

I believe this is finally fixed; see #8852. Can you try now, with HEAD?

Simon

comment:8 Changed 5 years ago by thoughtpolice

Resolution: fixed
Status: infoneededclosed

Looks fixed now after a quick attempt.

comment:9 Changed 4 years ago by gidyn

Cc: gideon@… marco.vax91@… jwlato@… removed
Note: See TracTickets for help on using tickets.