Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#9094 closed task (fixed)

remove RAW_CPP

Reported by: carter Owned by:
Priority: normal Milestone: 8.0.1
Component: Compiler Version: 7.8.2
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: #8683 Differential Rev(s): Phab:D648
Wiki Page:

Description

once the CPP settings ticket is merged #8683 one cleanup task is to remove the RAW_CPP bits from the ghc build system because they're not longer needed

Change History (9)

comment:1 Changed 5 years ago by Austin Seipp <austin@…>

In 460eebec65811c6a7bbe11645df322dda868e80d/ghc:

Remove RAWCPP_FLAGS

Summary:
#9094 mentions to "remove the RAW_CPP bits from the ghc build system because
they're not longer needed", "once the CPP settings ticket is merged #8683"

#8683 was merged with 34f7e9a3c99850859901ca74370f55f1d4e2279a, Phab:D26.

Test Plan: harbormaster

Reviewers: carter, austin

Reviewed By: austin

Subscribers: simonmar, ezyang, carter

Differential Revision: https://phabricator.haskell.org/D240

GHC Trac Issues: #9094

comment:2 Changed 5 years ago by thoughtpolice

Resolution: fixed
Status: newclosed

This should now be fixed.

comment:3 Changed 5 years ago by thomie

Resolution: fixed
Status: closednew

Please revert that commit, it is the cause of #9828.

comment:4 Changed 5 years ago by Herbert Valerio Riedel <hvr@…>

In 0511c0ab09f705c3012b405781c9398a143b0e38/ghc:

Revert "Remove RAWCPP_FLAGS"

This reverts commit 460eebec65811c6a7bbe11645df322dda868e80d.

Thomas requested to revert the commit with the words:

> Please revert this commit, it is horribly wrong. I'll have a proper look
> later, but not supplying `-traditional` to the C preprocessor is the cause
> of #9828.

the reverted commit was related to #9094

comment:5 Changed 5 years ago by thoughtpolice

Milestone: 7.10.17.12.1

Moving to 7.12.1 milestone; if you feel this is an error and should be addressed sooner, please move it back to the 7.10.1 milestone.

comment:6 Changed 5 years ago by thomie

Blocked By: 8683 removed
Differential Rev(s): Phab:D648
Status: newpatch

comment:7 Changed 5 years ago by Austin Seipp <austin@…>

In 555eef1d0fb5a7fd07971c1201b3c520f01125d4/ghc:

Remove RAWCPP_FLAGS (Task #9094)

Reviewers: carter, austin

Reviewed By: austin

Subscribers: thomie

Differential Revision: https://phabricator.haskell.org/D648

GHC Trac Issues: #9094

comment:8 Changed 5 years ago by thoughtpolice

Resolution: fixed
Status: patchclosed

Merged, thanks!

comment:9 Changed 4 years ago by thoughtpolice

Milestone: 7.12.18.0.1

Milestone renamed

Note: See TracTickets for help on using tickets.