Opened 13 years ago

Closed 13 years ago

Last modified 6 years ago

#931 closed bug (duplicate)

-caf-all gives "Error: symbol `Mainmain_CAF_cc_ccs' is already defined"

Reported by: igloo Owned by:
Priority: normal Milestone: 6.6.1
Component: Profiling Version: 6.5
Keywords: Cc:
Operating System: Linux Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

With this module:

module Main where

x = f [1..5] (f [2..] [3..])

f xs ys = l
    where
    l = [ if s then x else y | (x, y) <- zip xs ys ]
    s = g xs ys
    g [] _ = True
    g _ [] = False
    g (x:xs) (y:ys) = g xs ys

main = print (show x)

compiling with -caf-all gives:

% ghc -prof -caf-all a.hs -o a
/tmp/ghc21918_0/ghc21918_0.s: Assembler messages:

/tmp/ghc21918_0/ghc21918_0.s:3039:0:
     Error: symbol `Mainmain_CAF_cc_ccs' is already defined

/tmp/ghc21918_0/ghc21918_0.s:3087:0:
     Error: symbol `Mainsat_CAF_cc_ccs' is already defined

/tmp/ghc21918_0/ghc21918_0.s:3103:0:
     Error: symbol `Mainsat_CAF_cc_ccs' is already defined

The failure is similar in 6.4.2 and almost-6.6.

Reported on the haskell-cafe list.

Change History (5)

comment:1 Changed 13 years ago by fis

Operating System: UnknownLinux

comment:2 Changed 13 years ago by fis

i reported this on haskell-cafe, because i didn't really expect it to be a bug. similar error messages can be produced on my machine with the much smaller module 'module Main where main = error ""', or anything else i tried.

can anybody actually reproduce this?

comment:3 Changed 13 years ago by igloo

Resolution: duplicate
Status: newclosed

It's reproducible, yes, and a duplicate of 249. Tested by prof001 and prof002.

comment:4 Changed 11 years ago by simonmar

Architecture: UnknownUnknown/Multiple

comment:5 Changed 6 years ago by Ian Lynagh <igloo@…>

In 0b4b8c0af0acf175ceac7281c86a6d0b61be7a4b/ghc:

Add tests for trac#249 and #931
Note: See TracTickets for help on using tickets.