Opened 5 years ago

Closed 5 years ago

#9715 closed bug (duplicate)

The most minimal Gloss project causes the profiler to fail silently.

Reported by: Yxven Owned by:
Priority: normal Milestone:
Component: Profiling Version: 7.8.3
Keywords: Cc:
Operating System: Windows Architecture: Unknown/Multiple
Type of failure: Runtime performance bug Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

If you do this:

cabal clean cabal configure --enable-library-profiling cabal configure --enable-executable-profiling cabal build dist\build\rogue\rogue.exe +RTS -p and run it for a few seconds before closing it.

it will create a rogue.prof file that contains nothing.

Attachments (2)

rogue.cabal (392 bytes) - added by Yxven 5 years ago.
Main.hs (234 bytes) - added by Yxven 5 years ago.

Download all attachments as: .zip

Change History (4)

Changed 5 years ago by Yxven

Attachment: rogue.cabal added

Changed 5 years ago by Yxven

Attachment: Main.hs added

comment:1 Changed 5 years ago by rwbarton

My guess is that gloss or a C library it uses is exiting abruptly and not giving the GHC RTS a chance to shut down and write out the profiling information. For example if I build with -debug instead of profiling and run with +RTS -Ds the output ends with

...
7f1da4134740: freeing capability 0
7f1da4134740: task exiting

whereas a Hello, World program prints

...
7f198b4fd700: freeing capability 0
7f198dbf5740: shutting down capability 0, attempt 1598
7f198dbf5740: task exiting
7f198dbf5740: freeing task manager, 0 tasks still running
7f198dbf5740: removed cap 0 from capset 0
7f198dbf5740: removed cap 0 from capset 1
7f198dbf5740: cap 0: shutting down
7f198dbf5740: deleted capset 0
7f198dbf5740: deleted capset 1

comment:2 Changed 5 years ago by thomie

Resolution: duplicate
Status: newclosed

This is most likely a duplicate of #6113. Feel free to re-open if you disagree.

Note: See TracTickets for help on using tickets.