Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#9969 closed bug (fixed)

panic in T7562

Reported by: nomeata Owned by: simonpj
Priority: normal Milestone:
Component: Compiler Version: 7.8.4
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Compile-time crash Test Case: T7562
Blocked By: Blocking:
Related Tickets: #7562 Differential Rev(s):
Wiki Page:

Description

Various people observe this test failure:

=====> T7562(normal) 869 of 4389 [0, 0, 0] 
cd ./typecheck/should_compile && '/home/jojo/build/haskell/ghc-validate/inplace/bin/ghc-stage2' -fforce-recomp -dcore-lint -dcmm-lint -dno-debug-output -no-user-package-db -rtsopts -fno-warn-tabs -fno-ghci-history -c T7562.hs   -fno-warn-incomplete-patterns >T7562.comp.stderr 2>&1
Compile failed (status 256) errors were:

T7562.hs:3:14: Warning:
    UNPACK pragma lacks '!' on the first argument of ‘Pair2’
    In the definition of data constructor ‘Pair2’
    In the data declaration for ‘Pair2’
ghc-stage2: panic! (the 'impossible' happened)
  (GHC version 7.11.20150108 for x86_64-unknown-linux):
	toIfaceBang

Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug

According to my logs, this was caused by changeset:9564bb8c84cbc0397a414e946cc8c28801f0fbe7/ghc

Change History (3)

comment:1 Changed 5 years ago by Simon Peyton Jones <simonpj@…>

In 327ce1d336c8fbdb068be900a187f96d1c60b851/ghc:

Return a [HsImplBang] from dataConImplBangs even with NoDataConRep

This fixes Trac #9969, a new crash in T7562 that I somehow missed when
fiddling with HsBang

comment:2 Changed 5 years ago by simonpj

Resolution: fixed
Status: newclosed

Fixed, apologies.

comment:3 Changed 4 years ago by thomie

Merged to 7.10 in commit ccb7d96da42663407f1cd73355821ca5a7f55e7f:

Author: Simon Peyton Jones <simonpj@microsoft.com>
Date:   Fri Jan 9 09:46:37 2015 +0000

    Return a [HsImplBang] from dataConImplBangs even with NoDataConRep
    
    This fixes Trac #9969, a new crash in T7562 that I somehow missed when
    fiddling with HsBang
    
    (cherry picked from commit 327ce1d336c8fbdb068be900a187f96d1c60b851)
Note: See TracTickets for help on using tickets.